iMovie HD 6:Turn Video into Home Cinema

Usage: The following demo scripts are designed for use in Apple Retail, Sales Channel, or in larger one-to-many Apple
presentations. Do not share the contents of this script or content with customers.

List of items needed for this demo:
« iLife ‘06
« iLife ‘06 Demo Refresh DVD
« Macintosh with G4 or greater processor.
« Mac OS v10.4.4 or higher (for iMovie HD themes)
- .Mac account recommended (Internet connection required)

Purpose:
. Feature the ease of use, creativity, and complete integration of the iLife, .Mac

Set-up/install items
« Insure you have added the appropriate demo content from the iLife ‘06 Demo Refresh DVD to your demo machine
« iMovies in the Movies folder (like Winter Road Trip) and iPhoto albums in iPhoto—specifically the “Winter Road Trip’
album.

U

Presentation Hints: Keep it light and breezy. Be excited and amazed by each feature, even if it seems commonplace.
Remember, for many customers (especially potential switchers), the things we take for granted on a Mac are often
revolutionary to them.

Structure:
This script consists of a series of individual modules. Depending on the time allotted, you can perform everything in its
entirety, or you can pick and choose the modules that work best for your situation.



Topic Step by Step Visual Guides Dialog
Introductio | . Hello everyone, my name is ,
n and I'm very excited to be here
today to show you iMovie HD 6 -
part of iLife '06. iLife ‘06 is Apple’s
fully integrated digital lifestyle
suite that also includes updates to
iPhoto 6, iDVD 6, GarageBand 3,
and iWeb. Let’s get started.
Apple- « Select Open and Existing Project - Do you take home movies? Do you
designed from the welcome screen and want an easy way to give those
iMovie choose Winter Road Trip 2007 (or iMovie HD movies Hollywood flair? iMovie HD
themes select Winter Road Trip 2007 7 [ 6 is the fastest way to create an
from the File > Open... menu) = [ amazing movie with professionally
§ _ produced scenes that incorporate

your video and photos.

« With the iMovie Winter Road Trip
2007 project open, rewind and
playback full screen

. Let it sink in with the customer....

« This is home video with Apple-
designed themes placed
between content to give any
movie professional polish.

Apple-designed iMovie themes
share consistent design elements
such as backgrounds, motion
graphics, titles, and effects. Each
theme includes movie scenes that
incorporate your videos and
photos and act as building blocks
for your movie.

They also include advanced
transitions, video and graphic
overlays and backgrounds, “lower
thirds,” and credits.
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« Point out the drop zones: this is where
they add their own photos and video
clips to personally customize these
themes.

« They can even customize the
titles throughout

. It provides professional polish
and wonderful structure to
quickly create a very
professional-looking movie

Using advanced animation and
compositing, as well as familiar
Drop Zones, your video clips and
photos can be combined with
backgrounds, frames, text, and
effects to create an incredible
blockbuster with minimal time and
effort on your part.

And some iMovie themes are
coordinated with iDVD themes and
iPhoto books and slideshows to
maintain a consistent look.

« Show how easy it is to make a theme
element.

- Within this Travel project, select the
themes tab

« Select Travel theme from the pop-up

| Road Trip
e Pass Through

Reflection - White
I Reflection — Black

You can see how easy iMovie
allows you to change themes.

« Select the Open theme element (note:
you may need to click another element
first and then click Open)

Travel

Theme Elements:

Chapter 1

Simply select Themes and chose
your favorite or most appropriate
for your project. We'll select Travel
for this video footage.

Select a theme element and you'll
see it preview in the main window.
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« Select Show Drop Zones

 Show Drop Zones 3

Now bring up your Drop Zone
palette

And simply customize it with your
own content: video clips and/or
photos. Use the iLife media
browser to get all of your digital
content easily.

- Here is the drop zone editor before
filling

Now simply drag and drop your
photos from the media browser

« Fill the drop zones with the photos
provided (which should be installed in
the iPhoto library—they came in a
folder called Winter Road Trip 2007.

- Note, in Drop Zone 3 we've left an open
space when populating the photos and
placed a video clip from the iMovie Clips
Pane here. You can do the same. We
used the clip Throwing Fries—Bobby
Riding is also a good clip here.

And we'll even select a video clip
from our Clips Pane
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- Add a title, Winter Road Trip 2007 P | TS |7 | And it's simple to add a custom
’_ Show Preview \ / Hide Drop Zones \ tltle
Title 1:  Winter Road Trip ZD[J}'|
Apoly )
+ You don't need to render it out—it will Now, if you like what you have you
simply loop. simply select Apply and it’s added
to your movie in the timeline.
You are previewing these in real
time. When you apply the theme,
the rendering happens in the
background.
View « Want to show a“demo reel” of the Watch this to see a sampler of the
Multiple themes to give a professional overview new Apple-designed iMovie
Open of all the different types—while themes that come with the new
Projects showing off multiple open projects? version.
« Run the iMovie Themes Demo Reel, it
Themes should also be in your Movies folder Go J
to the File menu and select Open
Demo Reel

+ Choose the iMovie Themes Demo Reel
project, without closing this one.
« Click rewind and full screen playback

DUR EPIC SURF MOVIES
A g e Ay
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« Resize both windows, making them
smaller, so you can see each a little
better.

« In the newly opened iMovie, copy a
video or audio clip from one movie’s
timeline to the other by simply clicking-
and-dragging from one to the other.

. It’s that easy..

« (Up to 10 open projects supported)

« Remember: don't save these projects if
you've made ANY changes.

iMovie lets you switch between
multiple open projects and copy
video and audio clips among
projects instantly.

Instead of having to close a project
to open a new one, you can now
copy and paste or drag and drop
clips between open projects.

Want to compare different “cuts” of
your video? Simply open multiple
versions of the same project and
pick your favorite one.

+ Close the demo reel project

« Then select Window > Show Full Video
Resolution (To grow the Winter Road
Trip project window to fill the screen)

‘Window [T
Minimize A
Zoom

Show Full Video Resolution
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Real-time « Click on a clip, like Bobby Riding, in the Experiment with 30 stunning new
effects Travel movie (be sure not to save any of video effects and see the results

these changes)

. A /-
\ H';H:I |f == Tl \ & |

0:18:22

Bobby riding

instantly.

iMovie lets you edit and preview
clips with effects in real time* in
the main window.

The final rendering happens in the
background. There’s no waiting for
video to render; you'll see the
changes as soon as you make
them.

iMovie takes full advantage of the
Mac OS X Core Video, which utilizes
the graphics processing unit (GPU)
of Mac video cards for hardware
acceleration

*Footnote: real time performance
depends on your system
configuration.

« Select the Editing pane tab

| Clips Themes Media Editing ‘ Chapters

. Select the Video FX tab, and scroll to the
Quartz Composer set of effects (these
are the new real-time, OS X Core Video
effects).

Titles

Transitions | Wideo FX Audic FX
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- Choose different Real-time effects
from the list labeled “Quartz
Composer”, like Pointillize, and you’ll
see the results instantly.

Titles Transitions

+ Reduce the Radius, in the controls at

the bottom of the Video FX pane to
fine tune the desired effect.

Wideo FX

Audio FX

To chose and render one of
them, simply Apply. The
rendering will not effect your
ability to still preview the effect
in real-time

The final rendering happens in
the background. There’s no
waiting for video to render; you'll
see the changes as soon as you
make them.

iMovie takes full advantage of
the Mac OS X Core Video,
which utilizes the graphics
processing unit (GPU) of Mac
video cards for hardware
acceleration

*Footnote: real time
performance depends on your
system configuration.

Scroll through the effects and
select Pointillize. Notice how it
previews right away.
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Cinematic | - Select Editing from the Panes. Click Create fantastic titles and text
Titling Titles. effects for your movies and see the
. Select a title, like Bounce Across “en SR ~ = results right away—and in the
« Show that it loops in the main window [ ""; N >/ - large, ,main preview window.
—and you can make changes. v g WSy . 84 Sub-pixel rendering and field
« Hot Tip: Using all of the Mac OS X font ' %‘l’f‘fﬂg Me blending gives you higher quality,
controls—by Control-clicking and \ R e smoother text that will always
selecting Font > Show fonts—you can s o impress your audience.
virtually full control over your title styles.
« (Footnote: real time performance
depends on your system configuration.)
New Audio | - Select the Editing pane tab The new iMovie Audio effects can
Enhanceme [aien | voames | sie [ croreer | help you sweeten or clean up your
nt Tools audio using Mac OS X Core Audio

technology.

Select the graphic equalizer (Graphic
EQ) and adjust the bass, midrange and
treble.

Preview, then Apply

Tides | Transitions | Video Fx

Graphic EQ
b

S SRR R e S

Clips ~ Themes = Media | Editing ‘ Chapters ‘

The new audio enhancements in
iMovie will make your movie
sound as great as it looks.

Noise reduction helps to reduce
the sounds of wind noise, camera
motors, and other potential audio
distractions.

A graphic equalizer, reverb, delay,
and other new audio effects let
you add more depth and clarity to
your soundtrack, while
“sweetening” the audio signal
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The easiest | - Position the playhead on the timeline Making a video podcast is as easy
way to where you'd like to add a chapter as making an iMovie.

Create a marker. And if you want an “enhanced”
Video « Select the Chapters pane tab. video podcast with chapter
Podcast markers and URLs, it’s as easy as

Clips Themes Media Editing Chapters 1

adding chapters, as you do for
movies going to iDVD.

Just click and type in a Chapter
name and a link. iMovie does the
rest. And you can publish this to
the Internet with iWeb—or copy
the podcast to your iPod with
iMovie’s Share capabilities.

. Click Add Marker, which will add a
chapter along with automatically
including a chapter image.

( Add Marker )

Chapter markers are great for your
iMovies, since they are used
automatically in iDVD to create
scene selection menus for
convenient DVD navigation.

. Typein a title
« To add a URL, double-click below the
title (example: http://www.apple.com )

But now you can also enhance
your video podcast by including
chapter markers that let viewers
access a scene.

You can also add URLs to your
podcast so viewers can directly
access information on the Internet
or even content in the iTunes
Music Store.
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« Click Share menu > iPod

— c; = "
=) Q = < f i v 4
Videocamera  quickTime  Email Bluetooth iDvD iPod iweb GarageBand

Send your movie to your iPod.

Your movie will be properly formatted for the iPod, sent to
iTunes and placed in your iTunes library. You can then use
iTunes to copy your movie to your iPod

Your movie will be compressed to 30 frames per second,
approximately 320 x 240, with H.264 video and 44.1kHz AAC stereo
audio. Estimated size: about 23.5 MB.

( Cancel )  Share )

Now you can enjoy and share your
movie in several ways:

This can be your video podcast.
Simply share to iWeb and publish
to the Internet, even submit your
podast to the iTunes Podcast
directory for the world to discover
(described in the iWeb project that
follows)

Or simply share it to your iPod (via
iTunes)
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